1942166 – Chip can’t be added to page: HTTP 404: Resource Chip not found

Symptom
The OData Pagebuilder Service call responds with one of the following errors:

  • In the SAP Fiori home page, tiles are not displayed correctly. They contain the ‘eyes-crossed’ icon. Other tiles which are assigned to the user by Groups may not be visible at all.
  • When saving a shopping cart as a tile, the tile is not added to the SAP Fiori launchpad. The HTTP response for POST request creating the tile contains an error ‘Resource Chip not found’. The HTTP status code is 404.

Reason and Prerequisites

  • In Database table /UI2/CHIP_CHDR there are entries indicating an error like “HTTP response failed for UI2 CHIP xml with path /BLA/. Return code: 0, reason: Not found”.
  • You run the request: /sap/opu/odata/UI2/PAGE_BUILDER_CUST/Chips(‘X-SAP-UI2-CHIP%3A%2FUI2%2FAPPLAUNCHER_DYNAMIC’) in the SAP NetWeaver Gateway client (Transaction /IWFND/GW_CLIENT) in the SAP NetWeaver Gateway system and you get a response containing “Failed to send HTTP request for UI2 CHIP xml”.

Solution

Actions
If in the database table /UI2/CHIP_CHDR there are entries indicating missing authorizations then check that the user has all authorizations of role SAP_UI2_ADMIN_700.

Try to configure the SSO correctly: Add parameters to instance profile:

  • login/create_sso2_ticket 2
  • login/accept_sso2_ticket 1

Another hint for a deeper analysis is to create an ICM trace:

  1. Execute Transaction SMICM
  2. Goto -> Trace Level -> Set -> 3 (standard List 1)
  3. Goto -> Trace File -> Reset
  4. Reproduce scenario
  5. Goto -> Trace File -> Display All
  6. If the trace says something like sso-ticket missing the system administration has to provide a client-certificate.

Make sure that ICF service /sap/bc/ui5_ui5/ui2/tilechips is active according to documentation “Setting Up the SAP Fiori Launch Page” in SAP Help.

Implement referenced SAP Note 1961957.

Post processing and Recheck
Having done your changes run the report /UI2/CHIP_SYNCHRONIZE_CACHE and check the errors are not in table /UI2/CHIP_CHDR any longer.
If your changes have not been effective you might have to run report /UI2/DELETE_CACHE_AFTER_IMP to clear the server side cache for PAGES.